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Preface

Thank you for purchasing CrossCore” Embedded Studio (CCES), Analog Devices development software
for Blackfin® and SHARC" processors.

Purpose

The CrossCore Software Licensing Guide describes how to manage licenses for CCES software.

Intended Audience

The primary audience for this guide is anyone who is working with CCES, a licensed product from
Analog Devices. It describes the product licensing options, installation, and activation. The guide also
includes the troubleshooting and FAQ sections for licensing issues.

Manual Contents

The manual consists of:
o Chapter 1, Licensing Overview

Describes the available CCES license types and licensing options.
o Chapter 2, Activating a License

Details how to install and activate a CCES license.
o Chapter 3, Administering a Corporate Domain License

Describes how to install and administrate a corporate CCES domain license.
» Appendix A, Troubleshooting

Explains commonly encountered error messages and provides answers to frequently asked questions.
o Appendix B, Licensing Support

Describes how to contact Analog Devices regarding licensing issues.
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Preface

What's New in this Manual

This is Revision 1.3 of the CrossCore Software Licensing Guide. In this revision, some procedures have
been modified to match the CCES online help style.

Technical Support

You can reach Analog Devices processors and DSP technical support in the following ways:
« Post your questions in the processors and DSP support community at EngineerZone":

http://ez.analog.com/community/dsp
o Submit your questions to technical support directly at:

http://www.analog.com/support

« E-mail your questions about processors, DSPs, and tools development software from CrossCore
Embedded Studio or VisualDSP++":

Choose Help > Email Support. This creates an e-mail to processor.tools.support@analog.com and
automatically attaches your CrossCore Embedded Studio or VisualDSP++ version information and
Ticense.dat file.

« E-mail your questions about processors and processor applications to:
processor.tools.support@analog.com

processor.china@analog.com
« Contact your Analog Devices sales office or authorized distributor. Locate one at:

http://www.analog.com/adi-sales
« Send questions by mail to:

Analog Devices, Inc.
Three Technology Way
P.0. Box 9106
Norwood, MA 02062-9106
USA

o Note:

For licensing support, contact Licensing Support.

Product Information

Product information can be obtained from the Analog Devices Web site and CrossCore Embedded
Studio online help system.
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Preface

Analog Devices Web Site

The Analog Devices Web site, www.analog.com, provides information about a broad range of products-
analog integrated circuits, amplifiers, converters, and digital signal processors.

To access a complete technical library for each processor family, go to http://www.analog.com/
processors/technical_library. The manuals selection opens a list of current manuals related to the
product as well as a link to the previous revisions of the manuals. When locating your manual title, note
a possible errata check mark next to the title that leads to the current correction report against the
manual.

Also note, MyAnalog is a free feature of the Analog Devices Web site that allows customization of a
Web page to display only the latest information about products you are interested in. You can choose to
receive weekly e-mail notifications containing updates to the Web pages that meet your interests,
including documentation errata against all manuals. MyAnalog provides access to books, application
notes, data sheets, code examples, and more.

Visit MyAnalog to sign up. If you are a registered user, just log on. Your user name is your e-mail
address.

EngineerZone

EngineerZone is a technical support forum from Analog Devices. It allows you direct access to ADI
technical support engineers. You can search FAQs and technical information to get quick answers to
your embedded processing and DSP design questions.

Use EngineerZone to connect with other DSP developers who face similar design challenges. You can
also use this open forum to share knowledge and collaborate with the ADI support team and your
peers. Visit Attp://ez.analog.com to sign up.

Notation Conventions

Example Description

File > Close Titles in bold style indicate the location of an item within the
CrossCore Embedded Studio IDE’s menu system (for
example, the Close command appears on the File menu).

{this | that} Alternative required items in syntax descriptions appear
within curly brackets and separated by vertical bars; read the
example as this or that. One or the other is required.

[this | that] Optional items in syntax descriptions appear within brackets
and separated by vertical bars; read the example as an
optional this or that.

Software Licensing Guide 3
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Example Description

[this, ..] Optional item lists in syntax descriptions appear within
brackets delimited by commas and terminated with an
ellipsis; read the example as an optional comma-separated
list of this.

.SECTION Commands, directives, keywords, and feature names are in
text with Tetter gothic font.

filename Non-keyword placeholders appear in text with Tetter
gothic font and italic style format.

Note: NOTE: For correct operation, ...

A note provides supplementary information on a related
topic. In the online version of this book, the word NOTE:
appears instead of this symbol.

v. Caution: CAUTION: Incorrect device operation may result if ...
CAUTION: Device damage may result if ...

A caution identifies conditions or inappropriate usage of the
product that could lead to undesirable results or product
damage. In the online version of this book, the word
CAUTION: appears instead of this symbol.

7.  Attention: ATTENTION: Injury to device users may result if ...

A warning identifies conditions or inappropriate usage of the
product that could lead to conditions that are potentially
hazardous for devices users. In the online version of this
book, the word ATTENTION: appears instead of this
symbol.
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Licensing Overview

This chapter describes licensing options available for CrossCore Embedded Studio (CCES) 2.0.0 users.
The following topics are covered:

o Supported Operating Systems
 System Requirements
« Note to VisualDSP++ Users
o Licensing Terminology
o License Types
o License Expiration and Subscription
o License Locking Options
o Licensing Options Summary
o Obtaining a License Serial Number
o Locating License Serial Numbers
« Getting a PC Ready for License Activation
If you have any questions related to CCES licenses or licensing, contact 7echnical Support.
g~ Note:
The software license agreement can be found in the Docs folder of the CCES installation.

Supported Operating Systems

CCES 2.0.0 supports the following operating systems:

« Windows" 7 Professional, Enterprise, or Ultimate (32- and 64-bit)

» Windows 8.1 Pro or Enterprise (32 and 64-bit)

» Windows Vista™ Business, Enterprise, or Ultimate SP2 (32-bit only)
o Ubuntu 14.04 (32 and 64-bit)

Software Licensing Guide
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Licensing Overview

Warning: Windows 7, Windows 8.1, and Windows Vista users may experience User Access Control
(UAC) related errors if the software is installed into a protected location, such as Program Files or
Program Files (x86). We recommend installing the software in a non-UAC-protected location.

System Requirements

Verify that your PC has these minimum requirements for the CCES 2.0.0 installation:

« 2 GHz single core processor; 3.3GHz dual core or better recommended
« 1 GB RAM; 4GB or more recommended

o 2 GB available disk space

e One open USB port

' Note:

A faster disk drive decreases the build time, especially for a large amount of source files. 4GB of
RAM or more will substantially increase the performance of the IDE.

' Note:

For proper viewing of documentation under Windows, Internet Explorer 9 or greater is
recommended.

Note to VisualDSP++ Users

CrossCore Embedded Studio is a new Analog Devices product: the graphical user environment and full
development tool chain for digital signal processor applications. Although some aspects of CCES
licensing are familiar to VisualDSP++ users, VisualDSP++ licenses themselves cannot be used with
CCES.

Licensing Terminology

License Installation

License installation is the process of entering valid license information into CCES. A license that has
been entered into CCES but not activated immediately is said to be “installed”.

License Registration

License registration is the process during which a user informs Analog Devices that a license has been
installed. License registration results in a validation code.

License Activation

License activation is the process of unlocking the functionality of a CCES product by registering your
serial number with Analog Devices. Activation includes license installation, registration, and validation,
all in one step.

License Validation

6 Software Licensing Guide
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Licensing Overview

License validation is the process of entering an Analog Devices validation code into CCES. License
validation completes the activation of an installed license.

License Types

Tool chain Evaluation Licenses

A tool chain evaluation license provides 90 days of use on activation after which it expires and becomes
permanently disabled.

If installed but not activated, this license allows 10 days of operation (grace or trial period) before it
expires and becomes disabled. The license can be re-enabled by activation.

A tool chain evaluation license can be activated once on a particular machine.
Add-in Evaluation Licenses

Certain add-ins (CCES software components), such as Micrium pC/OS-III" Real-Time Kernel for
CrossCore Embedded Studio, also have an evaluation license. Once activated, this license lets you install
the add-in. You can install versions of the add-in with release dates up to 90 days after activation (see
License Expiration and Subscription).

An add-in evaluation license can be activated once on a particular machine.
Full Licenses
A full license does not expire once it has been activated.

Activation starts the license subscription, determining which product versions are enabled based on
release date (see License Expiration and Subscription). Subsequent full licenses, called maintenance
licenses, can be purchased at a reduced cost to renew the subscription term for an additional year.

If installed but not activated, a full tool chain license allows 10 days of operation before it expires and
becomes disabled. The license can be re-enabled by activation.

« A full tool chain license can be activated a limited number of times, which allows the user to move the
installation to a different machine.

o A full license for an add-in must be activated to allow the add-in to install. There is no grace period
with this type of license.

License Expiration and Subscription

License expiration and subscription are related but distinct terms. License expiration refers to overall
viability of the license. For example, a tool chain evaluation license provides 90 days of use after
activation, then expires. A full license, on the other hand, does not expire after activation. See License
Types for more information.

License subscription determines what product versions you can use with a license. The subscription
starts when the license is activated and ends at the end of the subscription interval. Products released
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Licensing Overview

before the subscription ends can be used with the license. Products released after a subscription ends
cannot be used with the license.

A subscription example: A full license with a one year subscription interval is activated on June 1, 2014.
This license can be used with products that have release dates up to and including June 1, 2015. To use
products with release dates beyond this date, the user needs to activate a new license. Note that you
continue to use products that were released before the subscription ends even after the subscription
itself has expired. The subscription determines whether or not newer versions of the product may be
used.

To renew a subscription, a maintenance license must be purchased and activated. Contact your Analog
Devices sales office or authorized distributor. Locate one at Attp://www.analog.com/adi-sales.

License Locking Options
Node-Locked Licenses

Occasionally referred to as a single-user license or a per user license, a node-locked license is locked to
the machine host ID of a specific host computer and provides a single license “seat”. Once installed, the
product runs on that one computer only.

The machine host ID typically refers to the Media Access Control (MAC) address of the network card or
motherboard. CCES uses MAC addresses as host IDs and supports the use of multiple MAC addresses
in its licensing scheme.

Corporate Domain Licenses
Corporate domain licenses lock to a network domain name, such as *. subdomain.yourcompany.com.

A license locks to one specific type of host ID. The license locking option cannot be changed.

Licensing Options Summary

Licensing controls the operation and installation of the CCES 2.0.0 features and components. The
licensing options are summarized in the following tables.

Table 1. Licensing Options for CCES Tool Chain

Type Prefix Evaluation - EVAL Full - ADI
Applies to Full tool chain operation Full tool chain operation
(For add-ins, see the following
table.)
Expiration 90 days Permanent
Processor family Blackfin and SHARC Blackfin and SHARC
8 Software Licensing Guide
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Type Prefix Evaluation - EVAL Full - ADI

Locking options Node-locked Node-locked or corporate
domain

Subscription None 1 year

Table 2. Licensing Options for CCES Add-ins

Type Prefix Evaluation - EVAL Full - ADI

Applies to pC/OS-III add-in installation Add-ins installation

(For tool chain operation, see the
previous table.)

Expiration Permanent Permanent
Processor family Blackfin and SHARC Blackfin and SHARC
Locking options Node-locked Node-locked
Subscription 90 days 1 year

For example, an evaluation license for the CCES development tool chain EVAL-CCES-XXXX - XXXX-XXXX-
XXXX - XXXX - XXXX - XXXX:

o Has a serial number prefix of EVAL

« Allows use of the full development tool chain

« Expires 90 days after activation

o Allows use of Blackfin and SHARC processors

o Is node-locked to the MAC address (physical address of the network card) of a specific computer
 Does not have a subscription interval

A full license for the CCES development tool chain, ADT-CCES - XXXX = XXXX = XXXX = XXXX - XXXX - XXXX -
XXXX:

« Has a serial number prefix of ADI

« Is permanent once activated

o Allows use of Blackfin and SHARC processors

o Is node-locked to the MAC address of a specific computer or a corporate network domain name
 Has a one-year subscription interval

A full license for an add-in, such as Micrium pC/OS-III, ADT - LUCOS3T- XX XX - XXXX - XXXX - XXXX - XXXX -
XXXX - XXX Xz

o Has a serial number prefix of ADI

Software Licensing Guide 9
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o Is permanent once activated

« Allows use of Blackfin and SHARC processors

o Is node-locked to the MAC address of a specific computer
« Has a one-year subscription interval

Obtaining a License Serial Number

This section covers the following topics:

o Obtaining a Full License Serial Number

o Obtaining an Evaluation License Serial Number
g~ Note:

An evaluation license (EVAL) can be upgraded to a full license (ADI).

Obtaining a Full License Serial Number
To obtain a full license:
Purchase a full license from:

« Analog Devices directly. Call (800)262-5645, 781-937-2384, or go to the buy online facility at
http://www.analog.com/en/content/buy._online/fca.html.

« Depending on your location, an Analog Devices local sales office or authorized distributor. To
locate one, go to Attp://www.analog.com/salesdir/continent.asp.

A purchased copy of CCES is accompanied by an ADI serial number.

Obtaining an Evaluation License Serial Number
To obtain an evaluation license:
Install the CrossCore Embedded Studio software.

CCES offers a tool chain evaluation license the first time it runs. CCES also offers an evaluation
license for a Micrium pC/OS add-in the first time you install pC/OS.

' Note:

An evaluation copy of CCES is accompanied by an EVAL serial number.

Locating License Serial Numbers

It is assumed that the CCES software is installed, licensed, and running on your computer.

1. To locate a CCES license serial number:

a) Choose Help > Manage Licenses.

The Manage Licenses dialog box appears.

10
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Tip: Use the dialog box to look up information pertaining to CCES licenses installed on a
computer and perform various licensing tasks.

2. To copy a serial number of the license to the system clipboard:
a) Select the serial number.
b) Choose Copy serial number from the context menu.

3. To copy the entire license report to the system clipboard:
a) Click Report.

The License Report dialog box appears.
b) Click Copy.

Choosing Help > Email Support automatically creates an e-mail message to
processor.tools.support@analog.com, generates, and attaches the product information report to the
message.

Getting a PC Ready for License Activation

License activation requires TCP/IP network (Internet) access.
Ensure your PC is ready to activate a CCES license:

1. Connect your PC to the Internet.
2. Ensure that firewall settings allow interaction with the Analog Devices licensing server.
3. If your license is node-locked, ensure the computer has a valid MAC address:

a) On computers with Windows OS, you can view all current TCP/IP network configuration values
by running the following command at the command prompt: ipconfig/all

Docking or undocking a laptop can affect the MAC addresses availability.

Licensing Support

If you still are experiencing a problem after trying to solve it using the information in this guide, contact
Analog Devices, Inc.

E-Mail Support

You can obtain support via e-mail as follows:

Registration Support:

Contact Registration Support if you have any problems with registering or validating your license serial
number, or if you have lost your license serial number. Use the following e-mail address:

processor.tools.support@analog.com.
Processor Tools Support:

For all other queries regarding CCES licensing, contact Processor Tools Support. Use the following e-
mail address:

Software Licensing Guide 11
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processor.tools.support@analog.com.

Tip: Choosing Help > Email Support automatically creates an e-mail message to the above address,
generates, and attaches the product information report to the message.

Information Required by Support

Before contacting Customer Support regarding a licensing issue, document the problem.

Prepare to communicate the following information:

« Software version provided by the Help > About CrossCore Embedded Studio dialog box
o License serial number(s) in question

» Contents of 1icense.dat (if available)

« Screen captures of encountered error messages

Tip: Choosing Help > Email Support automatically creates an e-mail message to
processor.tools.support@analog.com, generates, and attaches the product information report to the
message.

12 Software Licensing Guide
Revision 1.3, May 2015


mailto:processor.tools.support@analog.com
mailto:processor.tools.support@analog.com

3

Activating a License

The chapter describes the processes of installing a license string (serial number) into the CCES
Integrated Development Environment (IDE) via the New License Wizard as well as activating the
license. CCES licenses are defined in Licensing Terminology.

The following topics are covered:

o Starting the New License Wizard
o Selecting a License Type

e Entering a License Serial Number
o License Activation Methods

e Activating a License in One Step
o Delayed License Activation
o Validating a License

Refer to the CCES online help for reference information about the IDE components related to software
installation and licensing.

Starting the New License Wizard
It is assumed that the CCES software is installed.
1. Start the New License Wizard:
o If CCES is run the first time, or a new licensed add-in product is installed:
1. Navigate to CrossCore Embedded Studio Environment via Windows Start menu.

A warning message appears.
2. Click Yes.

o If CCES is run the second time and thereafter:

1. Choose Help > Manage Licenses > New.

Software Licensing Guide
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Activating a License

The New License Wizard appears.
2. (Optional) Select your license type.

Selecting a License Type

It is assumed that the New License Wizard is launched (see Starting the New License Wizard and the
following figure).

" New License Wizard =] i
Select License Type

Choose the type of license that you would like to install,

@ Ido not have a serial number and would like to evaluate the product

Choose this option if you would like to install a 90 day evaluation license for the CrossCore®
Embedded Studio tools suite. Note that this only allows evaluation of the taol chain itself and does
not include Add-in products such as pCAOS-II™ or pC/USB™,

Ihave a serial number that I would like to activate

Choose this option if you have purchased a serial number that you would like to register and
activate, This option can be used for both the base tool chain as well as Add-in products,

'Z:?_'_ 3 | Next > ] | Cancel

Figure 1. New License Wizard: Select License Type Page

CCES license types are defined in License Types.
1. Depending on whether you want to evaluate or activate a CCES product, do one of the following:

o If you would like to evaluate a CCES product (do not have a serial number for a permanent/full
license):

1. Ido not have a serial number and would like to evaluate the product is selected by default.
Click Next.

The Select license activation method page appears.
2. Choose your license activation method (see License Activation Methods).

' Note:

You are bypassing the license installation step, while evaluating the CCES software, for 90
days.
« If you would like to activate a CCES product (have a serial number for a permanent/full license):

1. Select I have a serial number that I would like to activate.
2. Click Next.

14 Software Licensing Guide
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The Enter your serial number page of the New License Wizard appears.

2. (Optional) Enter your license serial number.

Entering a License Serial Number

It is assumed that the Enter your serial number page of the New License Wizard is open (see Starting the

New License Wizard and the following figure).

+ 7 New License Wizard

Enter your serial number

Ready to proceed...

and letters,

Serial number:

Please enter your serial number exactly as it appears on the registration card, CD sleeve, or
web site from which it was purchased. Be sure to include all dashes in addition to numbers

MNext > Cancel

Figure 2. New License Wizard: Enter your serial number Page

To enter a license serial number:

1. In Serial Number, enter the number exactly as it appears, including dashes.

Activating a License

Entering a valid serial number displays your computer’s host ID and enables the Next button.

2. Click Next.

The Select license activation method page appears.

3. (Optional) Choose your license activation method (see License Activation Methods).

License Activation Methods

The following sections describe the process of license activation, as defined in Licensing Terminology.

A license can be activated immediately or after a trial period. The license activation can be performed:

« In one step if your PC is on the TCP/IP network (Internet). This is the most convenient license
activation method, detailed in Activating a License in One Step.
« In three steps if your PC is not on the TCP/IP network. This method is referred to as delayed
activation and detailed in Delayed License Activation.

In step 1, you install the license. For tool chain licenses, this provides access to the entire CCES tool
chain until the specified license expiration date.
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Activating a License

In step 2, you register the license. This results in the validation code sent back to you via e-mail.

In step 3, you validate the license (enter the validation code sent to you). This unlocks the trial period,
making the license permanent.

0 Note:

Corporate domain licenses and node-locked licenses are installed in the same manner, but a
license file containing a corporate license can be distributed (Distributing a License File) to
multiple computers on the corporate domain. For more information about administering
corporate domain licenses, refer to Administering a Corporate Domain License.

Activating a License in One Step

If your computer has an Internet connection, to activate a license in one step is the most convenient
method.

It is assumed that:

1. Your PC is ready for the one-step activation; see Getting a PC Ready for License Activation.

2. The license serial number is entered in the New License Wizard; see Entering a License Serial
Number.

3. The Select license activation method page of the wizard is open (see Selecting a License Type), and
Install and activate a license on-line all in one step is selected (as in the following figure).

27 New License Wizard = [@ =)

Select license activation method
Select the right CrossCore Embedded Studio license activation method foryou,

Please select one of the following activation methods:

@ Install and activate a license on-line all in one step

If you have Internet access, this is the easiest way to install, register, and validate your
license.

Install a temporary license and then register it via website
Complete the online registration form and a validation code will be e-mailed to you, Once

you have the validation code you can then enter it by clicking the Validate.., button in the
Manage Licenses dialog to unlock the product.

(2 l < Back Next > Cancel

Figure 3. Activating a License in One Step

' Note:

If your computer does not have an Internet connection, or such a connection is isolated, select
Install a temporary license and then register it via website and choose the Delayed License
Activation method.

16
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Activating a License

To activate the license in one step:
1. Click Next.

The Prepare for one-step license activation page appears.
2. Fill in the form.

The required fields are marked by an * (asterisk).
3. Click Next.

The Prepare for one-step license activation (continued) page appears.
4. Complete the form.
5. Click Finish.

The Your license has been successfully activated message (in the following figure) concludes the one-
step license activation.

5

.7 CrossCore Embedded Studio (=]

o Your license has been successfully activated,

oK

Figure 4. Your license has been successfully activated Message
6. Click OK to return to the IDE.

You successfully registered and activated your copy of the CCES 2.0.0 software. If you receive an error
message during this procedure, refer to 7roubleshooting.

Delayed License Activation

The delayed activation enables a customer to use the CCES tool chain for a specified trial period; the
license activation date is delayed.

o Note:

CCES add-ins also support delayed license activation. Once these licenses are activated, they
permit add-in installation.

It is assumed that:

1. The license serial number is entered in the New License Wizard; see Entering a License Serial
Number .

2. The Select license activation method page of the wizard is open; see Selecting a License Type.
g~ Note:

If your computer has access to the Internet and Analog Devices licensing server, install and
activate the license in one step. Keep the default selection, Install and activate a license on-line all
in one step and refer to Activate a License in One Step.
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Activating a License

If your computer does not have access to the Internet or Analog Devices licensing server, to
activate the license:

1. Select Install a temporary license and then register it via website (as in the following figure).

o7 New License \Wizard =

Select license activation method

Select the right CrossCore Embedded Studio license activation method far you,
Please select one of the following activation methods:

Install and activate a license on-line all in one step

If you have Internet access, this is the easiestway to install, register, and validate your
license.

@ Install a temporary license and then register it via website
Cormplete the online registration form and a validation code will be e-mailed to you. Once

you have the validation code you can then enter it by clicking the Validate... button in the
Manage Licenses dialog to unlock the product.

(2;: < Back Mext: [ Finish E | Cancel

Figure 5. Delayed License Activation
2. Click Finish.

The License Registration Instructions Web page appears (see the following figure).
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The serial numeses has been success

ully ertered and the foliowng bcense was instalied: Full, Mot Valkdated. Exprng in 10 days

These instructions describe how 1o register your product, obtan a validation code. and activale your icense. The instructions vary depending on whether o nal your system
Pars Intemet Access

1. Open the Licerse Regstration page in your Wab biowser

2 Fillin the requred informaticn

3 Submt the page

4. You wil recene the valdation code for your ktense via emai

& Inthe IDE Help > Manage Licenses dialog, sekect your serial numibes, then Validate

My system dous nat have internst access

1. On & systemn that does have Inlermet access, open the License Registration page al

analog.comForm_Page:

2 Fillin the requred information, including senal rumber and machine Host ID, from this table or the fle at the link al the 1op of this page
Serial number,

Machine Host I

3 Subiwit the page
4. You wil recene the valdation code for your icense via emai
% Inthe IDE Holp > Manage Licenses daiog, select your senal number, then Validate

H you need lechnical assistance with licersing andior activation contact Analog Devices Processor Tooks Registration Support at 1-800-ANALOGD (1-900-262-5543) or e-mai
b OSSO noks regetrabonglanaks) com

Figure 6. License Registration Instructions Page
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Activating a License

The License Registration Instructions page indicates that your license is installed but not registered.
At this point, a CCES tool chain license provides 10 days of unrestricted tool chain use. The page
describes how to register your license, obtain a validation code, and complete activation of your
license, with or without Internet access.
g~ Note:

Licenses for CCES add-ins install but are not valid until registered and activated.

3. Complete the registration process as instructed and submit the form.

Analog Devices processes your information and sends a validation code in email.

4. (Optional) Validate your license.

Validating a License

Once you receive a validation code for your CCES product from Analog Devices via email, complete the
license activation procedure.

It is assumed that the CrossCore Embedded Studio is installed and launched.
To permanently validate a license on a computer that is connected to the Internet:
1. Choose Help > Manage Licenses.

The Manage Licenses dialog box appears.

2. Select the serial number of the license that you want to validate.

Selecting a valid serial number enables the Validate command.
3. Click Validate.

The Enter Validation Code dialog box appears (see the following figure).

. 7 Enter Validation Code i

Enter the validation code which you should have received after completing the online registration
process, If you have not completed the registration process, click Cancel and then the Register
button to reqister.

Serial number:  EVAL-
Validation code: |

? OK Cancel

Figure 7. Enter Validation Code Dialog Box
4. In Validation code, enter the validation code sent to you.

Prevent typos by copying and pasting the license string.
5. Click OK.
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Activating a License

The successfully entered validation code results in a message indicating that a permanent license is
created.

6. Click OK.

The license serial number is added to the Manage Licenses dialog box. Note that the status icon next
to the license serial number has changed.

Search the online help for reference information about the IDE components related to software
installation and licensing.
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4

Administering a Corporate Domain License

This chapter describes how to create and install license files based on a corporate domain address.

Rather than locking to individual MAC (Ethernet) addresses, a corporate domain license locks to a
network domain, such as *. subdomain.yourcompany.com. A license file containing a corporate
domain license can be copied to multiple computers on the domain, potentially reducing overall
administrative overhead.

The following topics are covered:

o Determining Your Corporate Domain
e Locating a Corporate Domain License
o Activating a Corporate License

« Distributing a License File

Determining Your Corporate Domain

This procedure applies to computers with Windows operating system.

View all current TCP/IP network configuration values by running the following command at the
command prompt: ipconfig/all

' Note:

The corporate domain is the value of the primary Domain Name System (DNS) suffix. The
corporate domain license is locked to this value, so all computers that use this license must
have the same corporate domain value.

If the primary DNS suffix is blank, the computer is not on a domain, and a corporate domain
license cannot be used.
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Administering a Corporate Domain License

Locating a Corporate Domain License

« This procedure applies to computers with Windows operating system (Windows Vista, Windows 7, and
Windows 8).
o It is assumed that the CCES is installed on a computer that is on the corporate domain.

' Note:

If you already have installed (entered) a license and want to locate the license folder, follow the
procedure in Locating License Serial Numbers. The complete path to the license file is at the
beginning of the report.

The CCES installer creates a folder that holds license files on each computer.

Locate the license folder in <system drive>/ProgramData/Analog Devices/CrossCore
Embedded Studio.

' Note:

On some computers, the license folder may be a hidden system folder.

Activating a Corporate License

The process of activating a corporate domain license is similar to the process of activating a node-
locked license.

Follow the instructions in one of the following procedures:

e Activating a License in One Step
o Delayed License Activation

' Note:

Validation codes for corporate domain licenses are sent via email, regardless of the activation
method.

Distributing a License File

It is assumed that:

« CrossCore Embedded Studio software is installed on the target computers.

o The corporate domain license is obtained (see Obtaining License Serial Number) and activated ( see
Activating License Serial Number) on one of the computers to be covered by the license.

To distribute a corporate domain license on each computer to be covered by the license, do the
following:

1. (Optional) Back up, delete, or rename the existing license file.

The License Report dialog box (License Report) provides the location of the folder that contains the
license file.
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Administering a Corporate Domain License

2. From a computer on which the license is activated, copy the Ticense.dat file into the license folder
created by the CrossCore Embedded Studio installer.

CrossCore Embedded Studio now runs on the target computers.
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Troubleshooting

This chapter provides answers to common licensing problems and includes the following sections:

o Frequently Asked Questions (FAQs)
o Installation Error Messages
o Installation Warning Messages

If you still have questions related to CCES licenses or licensing after reading this chapter, contact
Technical Support or Licensing Support.

Frequently Asked Questions (FAQs)

This section describes some common questions arisen during license installation and validation.
Question: 7 have lost my serial number. Where can I find it, or how do I get a replacement?

Answer: You can locate already installed serial numbers in the CCES IDE: Help > Manage Licenses.
Refer to Locating License Serial Numbers for more information.

If you do not have CCES installed and licensed, e-mail Analog Devices with details of the person and
company to whom the serial number was originally registered. For more information, refer to 7echnical
Support.

Question: ['ve just installed a tool chain evaluation license using the “Install a temporary license and
then register it via website” option of the New License Wizard. Now I get a message telling me that the
license will expire in X days. I thought licenses were permanent?

Answer: When evaluation licenses are installed this way, they have an initial grace period. An
evaluation license runs for 90 days after activation. In order to unlock the complete evaluation period,
an evaluation license must be validated.

Full tool chain licenses installed via the Install a temporary license and then register it via website
option of the New License Wizard also have an initial grace period but become permanent when
validated. Refer to License Activation Methods for more details.
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Question: ['ve just installed a full license for a CCES add-in using the Install a temporary license and
then register it via website activation option of the New License Wizard. Now the status of the license
shows as ‘Expired. Doesn't this license have a grace period?

Answer: This type of license has no grace period: it must be validated to enable installation of its
component. Refer to License Types for details.

Question: What is the difference between license expiration’ and license subscription expiration’?

Answer: When a license is expired, it does not allow its products to be used at all. License subscription
applies to licenses that are not expired and allows product use based on a product release date. See
Licensing Terminology for more information.

Question: How do I transfer my license to a new machine?

Answer: Use the New License Wizard to activate your license on the new machine. If activation fails
with a message “7he license has already been registered the maximum number of allowed times,
request a registration history update via e-mail to processor.tools.support@analog.com. Include the
serial number(s) in question.

Question: How can I find out my registration history? That is, how do I find out which machines my
serial number(s) are registered against?

Answer: To request an up-to-date registration history, send an e-mail with the serial number(s) in
question to processor.tools.support@analog.com.

Question: ['ve just installed a license using the Install a temporary license and then register it via website
activation option of the New License Wizard. The validation code that was e-mailed to me is being
rejected. What could be the problem?

Answer: Validation codes are valid for a particular serial number and host ID combination. If you are
trying to activate your serial number on a second computer, you will have to register it on the new
computer in order to receive the appropriate validation code. For more information, refer to License
Activation Methods.

Question: Where is the license.dat file on my computer?

Answer: There is only one 1icense.dat file for all CCES installs on a computer, and the file is located
in the license folder. The full path to the license file is given in the report generated by Help > Manage
Licenses > Report or by Help > Email Support.

o Note:

The license folder may be a hidden system folder on some computers.
Question: How do I install both a node-locked license and a corporate domain license on the same
machine?

Answer: Licenses of all types can coexist on the same machine. Use the New License Wizard to activate
both licenses.

If you intend to install the corporate domain license on many machines, refer to Determining Your
Corporate Domain.
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Installation Error Messages

This section describes some common error messages issued during license installation and validation.

Problem: A valid license could not be found.

Click Yes to install a license at this time.

Click No to close CCES.

Solution: This message appears the first time CCES starts up or thereafter if there are no current licenses

installed. Selecting Yes starts the New License Wizard.

Problem: A valid license could not be found.

Click Yes to manage your license(s) now:

Click No to close CCES.

lEolution: This message appears if licenses have expired. Selecting Yes opens the Manage Licenses dialog
OX.

Problem: There was a problem installing the license for this serial number. Reason: Invalid license file.

The license file may be obsolete, corrupted, missing, or read-only.

Solution: This message indicates a problem with the /icense.dat file. For example, the license file is a
VisualDSP++ license file that is incompatible with CCES. Check the contents of /icense.datlocated in

<system drive>/ProgramData/Analog Devices/CrossCore Embedded Studio (on Windows Vista,
Windows 7, and Windows 8)

Also ensure that the file is not read-only. If the problem persists, contact 7echnical Support.
Problem: There was a problem installing the license for this serial number. Reason: A valid Host ID
could not be found.

Solution: Host ID information for your system can be found through the Manage Licenses dialog box in
the CCES IDE via Help > Manage Licenses > Report or Help > Email Support.

Licenses locked to an Ethernet (MAC) address require a physical TCP/IP network address to be
available on the computer. This error can occur if there is no network card installed.

Licenses locked to a disk serial number require a valid volume serial number. This error can occur if
there is no C: drive installed, for example.

Corporate domain licenses require that the computer be on a domain. Refer to Determining Your
Corporate Domain for more information.
Problem: 7here was a problem installing a license for this serial number. Reason: The serial number has

already been used and can be installed only once.

Solution: The serial number you are trying to install has been installed already on this computer. For
further information, refer to Licensing Terminology.
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Problem: 7here was a problem activating the license. Reason: There was an error during activation. This
may be due to the following:

« network outage
o firewall blocking access to the ADI activation server
 maintenance of the ADI activation server

Solution: This can occur during one-step activation. First, open a Web browser and confirm that you
can open the Attp://www.analog.com URL without any network or firewall problems. Then try
activating the license again in the New License Wizard. If you were on the last page of one-step licensing
activation when you closed the error dialog box, just click Finish again to complete activation.

If you still are unable to activate the license through one-step activation, on the Select license activation
method page of the New License Wizard, select the Install a temporary license and then register it via
website option. Follow the License Registration Instructions to register and validate your license.

Problem: 7here was a problem registering the license. Reason: The license has already been registered
the maximum number of allowed times. Details: Registration limit exceeded.

Solution: Full and evaluation licenses can be activated a limited number of times. Contact 7echnical
Supportwith your current serial number, and we will help to activate your current license or issue a
replacement license, depending on the circumstances.

Problem: 7he license was successfully installed, but there was a problem completing on-line validation.
You can register and validate your license manually by selecting Help > Manage Licenses.

Solution: The Manage Licenses dialog box lists the installed licenses. See License Activation Methods for
more information.

Problem: 7he license file was successfully installed, but there was a problem opening the registration
Web site.

Solution: This can occur due to a browser problem, for example. The Manage Licenses dialog box lists

the installed licenses. See License Activation Methods for more information.

Problem: 7here was a problem validating the license. Reason: The validation code is invalid. Please re-
enter the code, ensuring that you type the code EXACTLY as you received it. It might be helpful to
copy-and-paste your validation code rather than typing it manually.

Solution: CCES detected that you entered an invalid validation code. Ensure that you have entered the
correct validation code exactly as given.

Validation codes are valid for a particular combination of serial number and host ID. If you are trying to
install your serial number on a different computer than the one you initially registered, you need a new
validation code. Refer to License Types for details.

Installation Warning Messages

This section describes common warning messages issued during license installation and validation.
These messages display in message boxes, dialog boxes, the Console view, and the command prompt.

Warning (in message boxes): <serial number> expires in x days
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or
<serial number> expires today

Solution: If the given license has not yet been validated, it is in its grace period and will expire in x days
(or today). Refer to Validating a License for details.
g~ Note:

An evaluation license that has been activated also displays this message as it reaches the end of its
life.

Warning (in dialog boxes): 7he Subscription Expiration dialog box appears at startup if any license
subscriptions are due to expire soon.

Solution: To prevent the re-display of messages for these licenses, select Do not show this message for
these licenses again and click OK.

Warning (in the Console view or command prompt):

[Informational eal154]

License to use this tool will expire in x days

Solution: The assembler has detected that your license will expire in x days. If you have an evaluation
license or a full license, register and validate it.

Software Licensing Guide 29
Revision 1.3, May 2015



‘\ Y MOSCHIP RU g)?ﬂ%?aﬂ:wx KOMMOHEHTOB +7495668 12 70

© BMECTE Mbl CO3LLAEM BYOYLLEE B8 info@moschip.ru

O6LLecTBO C orpaHMYeHHON oTBETCTBEHHOCTBIO «MocHuny WMHH 7719860671 / KIMNM 771901001
Appec: 105318, r.Mockea, yn.LLlepbakoBckas 4.3, odmc 1107

[aHHbIn KOMMNOHEHT Ha TeppuTopun Poccuinickon depepauumn

Bbl MoxeTe npuobpectu B komnaHun MosChip.

[lnsa onepaTtuBHOro ocdopmnenus 3anpoca Bam HeobxoomMmo nepenT No faHHON CChISKe:

http://moschip.ru/get-element

Bbl MoxeTe pa3mecTuTb Y Hac 3aka3 and nboro Bawero npoekTa, 6yab To
cepuiiHoe Npomn3BOACTBO MM pa3paboTka eguHUYHOro npubopa.

B Hawem acCcCopTnMeHTe npencTasiieHbl Begywmne MmpoBblie NMPoOnN3BOANTENIN aKTUBHbIX U
NacCUBHbIX 3JTIEKTPOHHbIX KOMIMOHEHTOB.

Hawen cneumanusauuen sBnseTcs NOCTaBKa 3N1EKTPOHHOMW KOMMOHEHTHON 6a3bl
OBOWHOro Ha3HayeHus, npoaykummn Takmx npounssoantenen kak XILINX, Intel
(ex.ALTERA), Vicor, Microchip, Texas Instruments, Analog Devices, Mini-Circuits,
Amphenol, Glenair.

CoTpynHMyecTBO € rnobanbHbIMU OUCTPUOLIOTOPaMN 3NEKTPOHHBIX KOMIMOHEHTOB,
npegocTraBnseT BO3MOXHOCTb 3aKa3blBaTb 1 MOfly4aTb C MEXAYHAPOOHbIX CKNaaos
npakTuyecku nobon nepeyeHb KOMNOHEHTOB B ONTUMarbHble aAnsa Bac cpoku.

Ha Bcex aTanax pa3paboTKu 1 NPOM3BOACTBA HalLW NapTHEPbI MOTYT NOMy4YnTb
KBanumunpoBaHHy NOAAEPXKY OMNbITHbIX UHXEHEPOB.

Cuctema MeHeXMeHTa KayecTBa KOMNaHum oteevaeT TpeboBaHNAM B COOTBETCTBUM C
rOCT P MCO 9001, TOCT PB 0015-002 n 3C P, 009

Odomc no pabote c OPUANHECKUMU NTULLAMMU:

105318, r.Mockea, yn.lWepbakosckaa a.3, ocdomc 1107, 1118, AL, «LUepbakoBcKkuniny»
TenedoH: +7 495 668-12-70 (MHOrokaHanbHbIN)
dakc: +7 495 668-12-70 (006.304)

E-mail: info@moschip.ru

Skype otaena npogax:
moschip.ru moschip.ru_6
moschip.ru_4 moschip.ru_9


mailto:info@moschip.ru

